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About This Quick 
Start 

Considerations 
Related to Windows 

Software 

Welcome to the Tandem 
CD Read Product 
The Tandem CD Read product is a powerful resource that puts vast 
quantities of up-to-date technical information at your fingertips. It replaces 
bookshelves full of Tandem manuals and related publications with their 
electronic equivalent. 

The Tandem CD Read product is made up of two primary components: 

D CD Read libraries, which contain the electronic form of Tandem 
manuals and related publications 

D The CD Read viewer, which is a Microsoft Windows application that 
enables you to access the information stored in Tandem CD Read 
libraries 

The Tandem CD Read Quick Start for Microsoft Windows Software is intended 
for any Microsoft Windows user who wants to learn how to use the 
Tandem CD Read viewer to access information stored in a Tandem 
CD Read library. Using the basic techniques explained in this quick start, 
you will be able to locate information quickly within a library and its 
documents. 

If you are using the Tandem CD Read product for the first time, you should 
read or skim through all of this quick start to familiarize yourself with the 
viewer and the libraries. After that, use this quick start to refresh your 
memory before you perform tasks that you do infrequently. 

The Tandem CD Read viewer uses standard Microsoft Windows interface 
conventions. Instructions within this quick start often provide the formal 
route to obtaining a result. Short cuts or alternative routes to the same 
result are often available. 

For example, two such standard short cuts include: 

D Double-clicking to open an item instead of highlighting the item and 
then selecting the Open command 

D Pressing the return key to activate a default selection button 
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Welcome to the Tandem CD Read Product 

Where to Go for More Information 

If you are unsure about how to use the Microsoft Windows software, refer 
to the Microsoft Windaws User's Guide. 

When using this quick start, keep in mind that illustrations that depict 
standard Windows controls or dialog boxes reflect the most current version 
of Windows software. Windows controls and dialog boxes may appear 
differently in previous versions of the software. 

Where to Go for If you want additional information about the Tandem CD Read product, 
More Information refer to the Tandem CD Read Manual for Microsoft Windows Software. This 

manual is stored on the Tandem CD Read disc. 

For information on how to install the Tandem CD Read software and the 
CD-ROM hardware, refer to the installation manuals included with the 
Tandem CD Read product, or refer to the Tandem CD Read Manual for 
Microsoft Windows Software. ~. 

""-"' 
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1 Getting Started 
This section shows you how to begin using the Tandem CD Read product, 
including: 

D Starting the viewer 

D Getting help 

D Opening a library 

D Closing a library 

D Quitting the viewer 

How to Use the To use the Tandem CD Read viewer to access information stored in the 
Tandem CD Read Tandem CD Read libraries, do the following: 

Product 

l. Start the viewer. 

2. Locate and open a library. 

3. Select one or more documents from the library. 

4. Select and view pages from selected documents until you find the 
information you want. 

After you find the information you want, you can read it on the screen, 
mark it for future reference, and/ or print it. 

Starting the Viewer To start the viewer, use the Program Manager to navigate to the disk or 
directory that contains the viewer. Select the viewer icon, which is shown 
in the following illustration, by clicking on it, and then choose Open from 
the File menu: 

094578 Tandem Computers Incorporated 
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Getting Started 

Getting Help 

1-2 

To begin using the viewer, click on the following screen when it appears: 

002 

Getting Help When using the viewer, you will notice that most of the dialog boxes 
include a Help button. When you click on one of these Help buttons, the 
viewer displays the Help dialog and automatically selects the topic that 
pertains to the active dialog. 

As the illustration on the following page shows, the Help dialog displays 
available help topics in the left scrolling list; corresponding text for the 
selected topic is displayed in the right scrolling list. 
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Getting Started 

Getting Help 

Help 

Introduction ABOUT OPENING DOCUMENTS + -. ' . ....... 
Global Search By KeY\I -

Use this dialog to open a library of documents and then 
Global Search Limits one or more documents in that search library. 
Global Search By Num 
Printing Documents After opening a library, use one of three techniques to 
Page Navigation find a document 
Document Search 1. Scroll down the Found list to find a document title; 
Document Search Lirr double-cliclc on the title to open it. 
Marks 2. Cliclc: the By Number button to search for documents 

by part number. 
3. Click the By Keyword button to use the Global Search 

By Keyword dialog to find one or more documents 
containing specified search terms. Double-cliclc the 
tide returned from a search to open a document. 

I I 
The viewer maintains three document lists: 

Qlc - the list of All Documents in the library ,-
+ 

005 

If no dialog is active, or if you simply want to browse through the various 
help topics, choose Help from the File menu. The viewer displays the Help 
dialog and highlights: 

D The first help topic when you access the Help dialog for the first time 
during your current Tandem CD Read session 

D The last help topic you selected when you accessed the Help dialog 
previously during the current Tandem CD Read session 
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Getting Started 

Opening a Library 

1-4 

Opening a Library To open a library, choose Open from the File menu. The viewer displays 
the Document Selection dialog, which includes the standard controls (for 
example, buttons and lists) that you typically use with Windows 
applications to locate and open files: 

Document selection 

CDMASTER ,Name: ....._ ______ ___, 

files in: 
i Open '.'!'.ol j ~cd-m-a-st-er-.n-ti---~~ 

Directory list--1------- 1~~rom 

.Qocument List Shows 
0 Last l(cyword Search 
0 Last Number Search 

@ All Documents 

D f!oolanarb:d Docs Only 

Note 

~-~----~ 

! .Qpen Doc 11 !;.ancel 11 Help ... 

+ 

Global Search-----~ 

! By ,!;eyword I ! By Nymber 

003 

Use the Open Vol button and the directory list to navigate to the drive and 
directory that contain the Tandem CD Read library index file, named 
CDMASTER.NTI. If you are unsure about the operation of the standard 
Windows software controls, refer to your Microsoft Windows User's Guide. 

If the library you want to open is stored on a network server, you will not be able to access it 
unless you are connected to that server. To connect to a server, refer to instructions in the 
Microsoft Windows User's Guide. 
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Document list 

Getting Started 

Closing a Library 

When you open the drive or directory that contains the CDMASTER.NTI 
library index file, the viewer automatically opens the Tandem CD Read 
library and fills the document list on the Document Selection dialog with 
the names and part numbers of the documents in the library: 

Document selection 

CDMASTER Name: j CDMASTER.NTI 

files in: f:\softpubs 

! Open l[ol 

.Qocument List Shows 
0 Last Keyword Search 
0 Last Number Search 

@ All Documents 

D .6.oolanarted Docs Only 

• 11ss4 1 la 
FASTSORT Manual • 

• 12697 1 
Nonstop VLX System Operations Guide 

• 13259 1 
ENSCRIBE Programmer's Guide 

• 13851 1 
Subsystem Control Facility (SCF) Reference Manual 

• 13870 1 
Nonstop CLX System Planning and Installation Guide 

• 13978 1 
Installation Instructions for NonStop CLX 640/660 System 

! .Qpen Doc ! J &ancel 11 .!:!.elp... I 

Global Search-------, 

J By Keyword 11 By Nymber 
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Closing a Library The viewer does not provide a command that closes a library. Such a 
command is unnecessary because: 

D You do not need to close one library to open another one. Instead, use 
the controls on the Document Selection dialog to navigate to another 
library. 

D The viewer automatically closes the library that you opened when you 
quit the viewer. 
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Getting Started 

Quitting the Viewer 

---------------------------------------
Quitting the Viewer 

1-6 

To quit the viewer, choose Quit from the File menu. The viewer closes any 
libraries that are open and then quits, returning you to the Program 
Manager. 

To quit the viewer when the Document Selection dialog is active, first click 
the Cancel button on the Document Selection dialog and then choose Quit 
from the File menu. 

094578 Tandem Computers Incorporated 
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2 Working With Libraries 
When you open a library, the viewer automatically presents a list of the 
documents in that library. To continue, you must select one or more 
documents to view. 

If you know the title or part number of the document that contains the 
information you want, locate and open that document. If you do not know 
which document contains the required information, you can electronically 
search through the entire library-referred to as a global search-for 
documents containing the information you want. 

This section shows you how to: 

D Open a document by title 

D Open a document by number 

D Search a library 

D Open multiple viewing windows 

D Close a document 

Opening a Document Most Tandem CD Read libraries order documents alphabetically by title. 
by Title Consequently, you can quickly locate and open a particular document as 

follows: 

1. If the Document Selection dialog is not active, choose Open from the 
File menu and navigate to the CDMASTER.NTI index file. 

2. Scroll through the document list on the Document Selection dialog until 
you see the title of the document you want. 

3. Click on the document title to select it. 

4. Click the Open Doc button to open the selected document. 

The viewer opens the document in a new viewing window and displays the 
first page of the document. You are now ready to select pages from the 
document, as described in Section 3, "Accessing Information Within a 
Document." 
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Working With Libraries 

Opening a Document by Number 

Opening a Document If you know the Tandem part number of a document, you can search for 
by Number that number and then open the document as follows: 

1. If the Document Selection dialog is not active, choose Open from the 
File menu and navigate to the CDMASTER.NTI index file. 

2. Click the By Number button in the Global Search area of the Document 
Selection dialog. The viewer displays the Global Search By Number 
dialog: 

Global Search By Number 

Ok ! I Reset 11 Cancel 11 Help ... 

007 

3. Enter the part number of the document you want and click the OK 
button. 

The viewer closes the Global Search By Number dialog and searches the 
library for the document whose part number matches the number you 
requested. The viewer then presents the document in the document list 
on the Document Selection dialog. 

A partial entry in the Global Search By Number dialog presents all 
documents whose leading characters match the entry. For example, 
entering the number 014 shows all documents whose part numbers 
begin with 014 (014801, 014882, 014948). 

~ 
4. Click on the document you want to open if the document is not already ......,,,,, 

highlighted. 

5. Click the Open Doc button to open the selected document. 
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Working With Libraries 

Searching a Library 

The viewer opens the document and displays the first page of the document 
in a viewing window. You are now ready to select pages from the 
document, as described in Section 3, "Accessing Information Within a 
Document." 

Searching a Library When you do not know which document in a library contains the 
information you want, you can globally search through a library: 

D By keyword (that is, a word related to the information you want) 

D For documents that match a specific function and type 

D Both by keyword and by function and type 

To start searching a library by any of these methods, choose Open from the 
File menu if the Document Selection dialog is not active. Then, dick the By 
Keyword button in the Global Search area of the Document Selection 
dialog. The viewer displays the Global Search By Keyword dialog: 

Global Search By Keyword 

!5;eyword: 

~ Clear List Before Add D !;xpand Acronyms 

.------,Add 'I ~.· f!ele1e I 
Bevert I .__ ____________________ .,__, 

Documents found: O ~how: @ !itle O Number 

-+ 

I Qpen Doc 11 Set limits ! I Cl_!!ar Limits ! !;ancel 11 !:!elp ... 

011 
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Working With Libraries 

Searching a Library 

~ 
Searching by Keyword You use the keyword field and the controls located on the top half of the .....,I 

2-4 

Global Search By Keyword dialog to specify the keywords that the viewer 
uses to search for information. As the three buttons to the left of the 
keyword list suggest, you can: 

D Add a new keyword to the keyword list 

D Delete a selected keyword from the keyword list 

D Revert to a previous keyword list by removing all keywords that follow 
the selected keyword 

The viewer searches the library each time you change the keyword list, 
finding all instances of documents that contain the keywords on the most 
recent keyword list and presenting its results in the Documents Found list. 

Adding a Keyword 

To add a new keyword, follow these steps: 

1. Enter the keyword in the Keyword field at the top of the dialog. 

If you want to search for only the new keyword, check the Clear List 
Before Add box. If the keyword is an acronym, such as LAN (local area 
network), and you want the viewer to search for the acronym or the 
phrase it represents, check the Expand Acronyms box. 

2. Click the Add button. 

As illustrated on the following page, the viewer displays documents in 
the Documents Found area of the dialog that contain the keywords that 
you specified. 
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Keyword field 

Keyword list 

Working With Libraries 

Searching a Library 

Global Search By Keyword 

J:;eyword: TACL 

D Clear List Before Add D fxpand Acronyms 

I Add I tandem + ,-
system 

I I 
,-

!).1:lele command 

I .Bevert I operation 
configure '+ 

Documents found: 196 ~how: ® !itlcs 0 Numbers 

3650/6100 Communications Controller Architecture Manual + ,-
5200 Optical Storage Facility (OSF) Reference Mnl ,-
6100 ADCCP Programming Manual 
6100 MPS-8 Programming Manual 
6100 MPS-TINET Programming Manual 
AM3270 Management Programming Manual 
Asynchronous Terminal &. Printer Process Programming Manual + 

I Qpen Doc 11 Set J..imits I j Cl.!!_11r Limits I I ~ancel 11 !:!.elp ... I 
006 

After you add a keyword, the viewer may report that it finds no documents 
that contain the keywords specified on the list. This response usually 
indicates that you have specified a list of keywords that do not appear in 
any of the documents in the library. It may, however, indicate that you 
have added a keyword that the viewer cannot recognize. For the viewer to 
recognize a keyword, the word: 

0 Must contain only letters, digits, underscores, and hyphens. 

0 Must not start or end with an underscore or hyphen. 

0 Must be at least 3 digits long if it is a number. 

0 Must be at least 2 characters long if the word begins with a letter. 

0 Must not be longer than 35 characters. 

D Must not be a stop word. Stop words are a special list of words that are 
not recognized by the viewer as keywords because they occur so 
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Working With Libraries 

Searching a Library 

frequently that they appear in every document in a library. Examples ~ 
of common stop words are "the," "and," "that," and "in." ...,,,I 

Deleting a Keyword 

To delete a keyword, follow these steps: 

1. If necessary, use the scroll controls on the keyword list to locate the 
keyword that you want to remove. 

2. Select the keyword. 

3. Click the Delete button. 

The viewer removes the keyword from the keyword list and automatically 
performs a new search using the revised list. 

Reverting to a Previous Keyword List 

To revert to a previous keyword list, follow these steps: 

1. If necessary, use the scroll controls on the keyword list to locate the last 
keyword in the list that you want to use. 

2. Select the keyword. 

3. Click the Revert button. 

The viewer deletes all keywords that follow the selected keyword and 
automatically performs a new search using the revised list. 

Searching by Function and Each Tandem CD Read library defines a set of functions and a set of types 

2-6 

Type that apply to the documents in the library; each document in the library is 
classified by one function and one type. In general, functions group 
documents by the subject they discuss, while types group documents by the 
category of information they provide about their subject. 

For example, TACL is a function because it refers to a specific subject within .~ 
the library. Programming is a type because it refers to a category of ·......,/ 
information (in this case, programming information). By selecting TACL 
from the Function List and Prograrruning from the Type List, you limit the 
search to documents containing information on TACL prograrruning. 
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Working With Libraries 

Searching a Library 

To search for documents that match a specific function and type, dick the 
Set Limits button on the Global Search By Keyword dialog. The viewer 
displays the Set Global Search Limits dialog, which contains the Function 
List and the Type List: 

function List 
AM3270 
AM3270{TR3271 
AM652D 
ATP6100 
BASIC 
CLX 
COBOL 
CP6100 
CROSS-PRODUCT 
CUP 
CYCLONE 
DEBUG 
DSC 

D All Functions 

Set Global Search L1m1ts 

+ 
I-

I-

t
+ 

CONAGURATION 
HOWTOUSE 
INTRODUCTION 
OPERATIONS ANO MANAGEMENT 
PROGRAMMING 
SUMMARY 
OTHER 

OAJIType~ 

Ok ! I Cancel ! I Help .•• 

014 

To select the functions and types you want included in the library search: 

D 

D 

D 

D 

D 

Click on a function or type to select just that function or type. 

Drag through several functions or types to select all of them. 

Hold down the shift key when clicking or dragging to select or deselect 
continuous functions or types. 

Hold down the control (Ctrl) key when clicking or dragging to select or 
deselect discontinuous functions or types. 

Check the All Functions or All Types box, if they are not already 
selected, to select all functions or all types. 

After you have selected the functions and types you want, click the OK 
button. The viewer doses the Set Global Search Limits dialog, searches for 
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Working With Libraries 

Searching a Library 

documents that match the search criteria, and displays the documents in the ·""""" 
Documents Found list on the Global Search By Keyword dialog. ·.....,I 

The viewer uses the functions and types you have selected until you change 
them, open another library, or click the Clear Limits button on the Global 
Search By Keyword dialog. If you click the Clear Limits button after 
searching by function and type, the viewer deletes all documents from the 
Documents Found list and resets the All Functions and All Types boxes to 
their default setting. 

Searching by Both Searching a library by both keyword and function and type is useful when 
Keyword and Function and your initial search either by keyword or by function and type produces a 

2-8 

Type list of documents that is too long to review. Combining the search 
techniques allows you to limit the documents selected by the viewer to a 
shorter list of documents that you can then open individually. 

To search by both keyword and function and type, first specify keywords ~. 
on the Global Search By Keyword dialog. Refer to "Searching by Keyword" ..._) 
earlier in this section for instructions. After specifying keywords, click the 
Set Limits button and select the appropriate functions and types on the Set 
Global Search Limits dialog. Refer to "Searching by Function and Type" 
previously in this section for instructions. 

After you have selected the functions and types you want, click the OK 
button. The viewer closes the Set Global Search Limits dialog, searches for 
matching documents, and displays on the Global Search By Keyword 
dialog all documents that: 

D Have as their function one of the functions you selected 

D Have as their type one of the types you selected 

D Contain all the keywords on the keyword list 

If you click the Clear Limits button after searching by both keyword and 
function and type, the viewer redisplays in the Document Found list those 
documents that match the keyword search only; the search limits that you 
imposed by selecting specific functions and types using the Set Global 
Search Limits dialog no longer apply. 
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Working With Libraries 

Opening Multiple Viewing Windows 

Opening a Document After To open one of the documents shown on the Documents Found list after 
Searching performing a library search, click on the document title or number in the list 

and then click the Open Doc button. The viewer opens the document and 
displays the first page of the document in a viewing window. You are now 
ready to select pages from the document, as described in Section 3, 
"Accessing Information Within a Document." 

If, after viewing the document you opened, you want to look at one of the 
other documents on the Documents Found list, you can use the Next Doc 
in List or Previous Doc in List command from the File menu. When you 
choose one of these commands, the viewer replaces the document you are 
viewing with the next or previous document that appears in the Documents 
Found list. 

Opening Muftiple The viewer supports having more than one viewing window open at a 
Viewing Windows time. Use the multiple windows feature when you want to: 

D View more than one location in the same document at the same time. 
For example, you might want to display a document's table of contents 
or index in one window and a page referenced in that table of contents 
or index in another window. 

The table of contents and index are primary entry points into a 
document. Refer to "Using a Document's Table of Contents" and 
"Using a Document's Index" in Section 3 for more information on how 
to use these components to locate information within a document. 

D View more than one document describing a particular topic. For 
example, you might want to open the Guardian 90 Operating System 
User's Guide and then display other manuals referenced in the user's 
guide. 

The number of viewing windows you can open is limited only by how 
much memory (RAM) you have on your computer. The technique to open 
additional viewing windows is exactly the same as the one for opening the 
first viewing window. 
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Working With Libraries 

Closing a Document 

To open additional windows, do the following: 

1. Open another session of the viewer from the Microsoft Windows 
Program Manager. 

2. Select Open from the File menu. 

3. Locate the document you want to open using a method explained 
previously in this section under "Opening a Document by Title," 
"Opening a Document by Number," or "Searching a Library." 

4. Select the document title from the Document List on the Document 
Selection dialog or the Documents Found list on the Global Search By 
Keyword dialog. 

5. Click the Open Doc button to open the document. 

Closing a Document The viewer does not provide a menu command to close a document. 

2-10 

However, it is not necessary for you to close a document because: 

D You do not need to close one document to open another one. Use the 
Next Doc in List and Previous Doc in List commands from the File 
menu to replace the current document with the next or previous 
document in the Document Found list; these commands automatically 
close the current document. 

D The viewer automatically closes the open document when you quit the 
viewer by choosing Quit from the File menu. 
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3 Accessing Information 
Within a Document 

When you open a document in a library, the viewer opens the document 
and displays the first page of the document in a window. Once the 
document is displayed, you can: 

D Navigate directly to specific parts of a document 

D Use the document's table of contents to select which pages you want to 
view 

D Use the document's index to select which pages you want to view 

D Search through the document for pages that contain the information 
you want 

Navigating to Parts of Most libraries contain documents that are divided into parts, including: 
aDocument 0 Table of contents 

D Preface 

D Chapters (alternatively called sections) 

D Appendix 

D Glossary 

D Index 

If the document you are viewing is divided into parts, you can use the 
navigating commands on the Page menu to go directly to the first page of 
each of these parts. For example, if you select the Preface command from 
the Page menu, the viewer automatically displays the first page of the 
document's preface. If you select the Index command from the Page menu, 
the viewer automatically displays the first page of the document's index. 

The Chapter and Page and Absolute Page commands, however, differ from 
the other navigating commands because they display dialog boxes. These 
dialogs are illustrated on the following page. 
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Accessing Information Within a Document 

Navigating to Parts of a Document 

3-2 

freface Ctrl P 
Iable of Contents Ctrl T 

!;hapter and Page ... Ctrl C 
Absolute Page ... Ctrl G 
Appendix Ctrl A 
lnde;!!; 
Glossarx 

Zoom In F3 
Zoom Out F4 
.f!!.ormalView 
Microfilm View 

Chapter 2 
Chapter 3 
Chapter 4 
Chapter 5 
Chapter 6 

Chapter 1 

Chapter and Page 

fage: !=ii _ ___. 

Ole I ! !;ancel ! J .!:!elp ... 

Absolute Page 

Eage: !=ii _ ___. 

Ok I ! ~ancel ! J .!:!elp ... 

.. 
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The Chapter and Page dialog enables you to go to a specific page within a 
specific chapter. To go to a specific chapter and page, select the chapter you 
want from the scroll list, enter the page number in the Page field, and click 
the OK button. 

The Absolute Page dialog allows you to go directly to a specific page 
regardless of whether the document is divided into parts. To go to a 
specific page, enter that page number in the Page field and click the OK 
button. 

The page panel, which appears in the lower left comer of each document 
window, displays both the absolute page number and the chapter and page 
number. The page panel is illustrated on the following page. 
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...... 

Dilk.Drir,es In all cabinets, the upper left slot in the tape and clisk section (slot 30) c 
contain either a disk drwe or a cartridge tape drwe. (Every system mu 
have at le.ast one tape drive-either a cartridge tape drwein slot 30 oft 
base system cabinet or .a freestanding 5160 open reel tape drwe.) In a 
s11stem that h.as fewer than we disk drwes, the remaining disk slots are 
filled with disk drwe filler :panels, shown in Figure 1 · 21. 

E.ach CLX disk drwe (Figure 1-20) contains the disk drr,.ie itself . .arnell 
tan and a :power supply for the drwe. The 4210 disk driv'e contains 145 
Megabytes of data: the 4220 drwe contains 300 MB. 

Page Panel-- Page 56 / Chapter 2 - Page 8 + + 
+ 
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Using a Document's If the document you are viewing has a table of contents, you can use that 
Table of Contents table of contents to locate information quickly: 

1. Open another viewing window on the same document using the 
technique described in Section 2 under "Opening Multiple Viewing 
Windows." This second window will be the table of contents window. 

As shown in the illustration on the next page, you may want to resize 
and reposition the viewing window for easier viewing of and access to 
each window. 

2. With the second viewing windows active, choose Table of Contents 
from the Page menu. The viewer displays the first page of the table of 
contents in the second window. 

3. Use the scroll controls on the right side of the viewing window to 
browse through the table of contents until you find a heading that may 
contain the information you want. Note the chapter and page number 
of the heading. 
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3-4 

4. Activate the document's initial viewing window by clicking on it or by 
choosing it from the Window menu. 

5. Choose Chapter and Page from the Page menu to display the Chapter 
and Page dialog. 

6. Select the chapter, enter the page number that you noted in Step 3, and 
then click OK to go to the page. 

If, after you have viewed the heading, you decide it does not contain the 
information you want, you can switch back to the table of contents window 
and repeat Steps 3 through 6. 
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file .E_dit Eage ,Search Mark 
+ 

Contents 
xvii Pref ace 

xxi Notation Conventions 

Section 1 Getting Started 
1- 2 Using TAC L as a CoII1Inand Interpreter 

1- 3 Entering TACL Commands 

1- 5 Log.sing On With T ACL 

file fdit Eage ~earch Mark 

Using TACL as a 
Command Interpreter 

p.,ge 23 / Ch.,pt..- 1 - P;og~ 2 
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Tan em A wnce Com man Language TACL 

TACl. Programmer's Guid'efor more information. 

TACL is most often used interactively as a comman 

system startup, your system manager or operator st 

from the TACL program file for each terminal, inclu 

connected to the system. (The T ACL program file i 

$SYSTEM.SY5n n.TACL, where nn is a two-digit n 

You can then log on to the TACL process at your ter 

system. TheTACL LOGONcommand is described 

you are connected on a network, you can also start 

another system; see Section 3 for details.) 
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Using a If the document you are viewing has an index, you can use that index to 
Document's Index locate information quickly: 

1. Open another viewing window on the same document using the 
technique described in Section 2 under "Opening Multiple Viewing 
Windows." This second window will be the index window. 

As shown in the illustration on the next page, you may want to resize 
and reposition the viewing window for easier viewing of and access to 
each window. 

2. With the second viewing windows active, choose Index from the Page 
menu. The viewer displays the first page of the index in the second 
window. 

3. Use the scroll controls on the right side of the viewing window to 
browse through the index until you find an entry that you feel may 

· contain the information you want. Note the chapter and page 
references that follow the entry. 

4. Activate the document's initial viewing window by clicking on it or by 
choosing it from the Window menu. 

5. Choose Chapter and Page from the Page menu to display the Chapter 
and Page dialog. 

6. Select the chapter and enter one of the page numbers that you noted in 
Step 3, and then click OK to go to the page. 

If none of the references for the entry contain the information you want, 
you can switch back to the index window and repeat Steps 3 through 6, or 
you can use another search method to locate the information. 
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Index 
A 
ACTIVATE command in T ACL 3-6 
ADD DEFINE command in T ACL 5-10 
Alias definition in T ACL 4-3, 4-12 
ALTER command in FUP 7-24 
ALTER DEFINE command in TACL 5-10 

file ,Edit eage ~earch Mark 
Pag" + 

ACTIVATE Command Use the ACTIVATE command to reactivate a processt 

with the SUSPEND command. To reactivate the proc 

previous example, enter: 

11> /CI1VA1E 2, 99 
l2> 

lfyou do not specify a process in your ACTIVATE co 

reactivates the default process (the last process you st 

STOP Command Use the STOP command to stop a process that was start 

a process that :you no longer need. This example stops 

CPU and PIN number 2 99: + 
Pag" 69 I Chapt"r 3 - Pag" 6 + • 
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Searching a Document 

---------------------------------------
Searching a Document When you do not know which page in an open document contains the 

information you want, you can search through the document for keywords 
and narrow the search by setting search limits by document part and page. 

3-8 

To start searching an open document, first make sure that the document is 
in the active window. Then, choose Document Search from the Search 
menu. The viewer displays the Document Search dialog: 

Document Search 

Keyword: 

[81 Clear List Before Add D !;_xpand Acronyms 

,---,~d 11 ~++ _!!elete I 
_Revert I 

~-------------------~ 
Pages found: O I 
.---------------.,....., §o To Page 

+ ~====: -_ ~I . Set J.imits 

I Cl.!!_ar Limits I 
tancel 

Help ... 

013 

Searching by Keyword You use controls located on the top half of the Document Search dialog to 
specify the keywords that the viewer uses to search for information. As the 
three buttons to the left of the keyword list suggest, you can: 

D Add a new keyword to the keyword list 

D Delete a selected keyword from the keyword list 

D Revert to a previous keyword list by removing all keywords that follow 
the selected keyword 
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Searching a Document 

The viewer searches the document each time you change the keyword list, 
finding all instances of pages that contain the keywords on the most recent 
keyword list and presenting its results in the Pages Found list. 

If you have previously conducted a global search of a library by keyword, 
the viewer places the keywords you used in that search into the keyword 
list for you. The viewer then performs a search of the pages in the 
document, using those keywords. 

When you perform a global search using two or more keywords and then open the 
Document Search dialog and perform a document search, the viewer may report that it finds 
no pages that match. This occurs because global searches check whether the keywords 
appear anywhere in a document, while document searches check whether the keywords 
appear on the same page. Though two keywords may appear in the same document, they 
may not appear on the same page. 

Adding a Keyword 

To add a new keyword, follow these steps: 

1. Enter the keyword in the Keyword field at the top of the dialog. 

If you want to search for only the new keyword, check the Clear List 
Before Add box. If the keyword is an acronym, such as LAN (local area 
network), and you want the viewer to search for the acronym or the 
phrase it represents, check the Expand Acronyms box. 

2. Click the Add button. 

The viewer displays the pages that contain the specified keywords in 
the Pages Found area of the dialog, as illustrated on the next page. 
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Document Search 

Keyword: 

D Clear List Before Add D .!;_xpand Acronyms 

,--:-:-::-~-e .....,ii' ~-c-ti-v-at-e-------------------~~ 

Pages found: 9 I 
....---------------..,......., §.o To Page 

Page 12 / Table of Contents - Page 8 ..!. 
Page 63 / Chapter 2 - Page 15 ,- I Set .!..imits 
Page 73 / Chapter 3 - Page 10 I 
Page 90 / Chapter 4 - Page 14 Cigar Limits 
Page 91 / Chapter 4 - Page 15 
Page 102 / Chapter 5 - Page Io .!;.ancel 
Page 140 / Chapter 7 - Page 11 ..... 

+ Help ... 

027 ~ 

After you add a keyword, the viewer may report that it finds no pages that 
contain the keywords specified on the list. This response usually indicates 
that you have specified a list of keywords that do not appear on any single 
page of the document. It may, however, indicate that you have added a 
keyword that the viewer cannot recognize. For the viewer to recognize a 
keyword, the word: 

D Must contain only letters, digits, underscores, and hyphens. 

D Must not start or end with an underscore or hyphen. 

D Must be at least 3 digits long if it is a number. 

D Must be at least 2 characters long if the word begins with a letter. 

D Must not be longer than 35 characters. 

D Must not be a stop word. Stop words are a special list of words that are 
not recognized by the viewer as keywords because they occur so 
frequently that they appear in every document in a library. Examples 
of common stop words are "the," "and," "that," and "in." 
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Deleting a Keyword 

To delete a keyword, follow these steps: 

1. If necessary, use the scroll controls on the keyword list to locate the 
keyword that you want to remove. 

2. Select the keyword. 

3. Click the Delete button. 

The viewer removes the keyword from the keyword list and automatically 
performs a new search using the revised list. 

Reverting to a Previous Keyword List 

To revert to a previous keyword list, follow these steps: 

1. If necessary, use the scroll controls on the keyword list to locate the last 
keyword in the list that you want to use. 

2. Select the keyword. 

3. Click the Revert button. 

The viewer deletes all keywords that follow the selected keyword and 
automatically performs a new search using the revised list. 

Limiting a When searching a document for keywords, you can change the keyword list 
Document Search until you feel that the list of pages found is short enough to warrant looking 

at the pages themselves. If you cannot shorten the list of pages using 
keywords alone, you can direct the viewer to search only certain parts of 
the document. To do so, click the Set Limits button on the Document 
Search dialog. The viewer displays the Set Document Search Limits dialog 
illustrated on the next page. 
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Set Document Seorch Limits 

Search In Pages: from: E:::J To: ~ (up to 226) 

® Absolute Page Range (enter above) 

0 !able of contents (pages 3 through 7] 

0 freface (pages 8 through 1 OJ 

0 Chapter(s) Chapter 1 .,!. through 
Chapter 2 
Chapter 3 
Chapter 4 
Chapter 5 
Chapter 6 
Chapter 7 
Chaoter8 + 

0 Appendi;!!; (pages 200 through 213) 

0 Glossnry 

0 !ndex (pages 214 through 226) 

.QI: 11 ~ancel 11 Help ... 

Chapter 1 
Chapter 2 
Chapter 3 
Chapter 4 
Chapter 5 
Chapter 6 
Chapter 7 
Chaoter 8 

-

+ 

012 

Using the Set Document Search Limits dialog, you can limit a document 
search to: 

0 A specific part of a document that is divided into parts 

0 A single chapter or range of chapters in a document that is divided into 
parts 

0 A specific range of pages in any document, whether it is divided into 
parts or not 

To limit a document search, click the button next to the type of limit you 
want to set. 

If you choose to limit the search to a range of chapters, you can select the 
first and last chapter of the range you want the viewer to include in the 
search. 

If you choose to limit the search to a range of pages, you can enter page 
numbers in the From and To fields of the Search in Pages area of the dialog. 
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After selecting the limits you want, click the OK button. The viewer closes 
the Set Document Search Limits dialog, searches for the keywords you 
specified within the limits you selected, and displays any pages that match 
the search criteria in the Pages Found list on the Document Search dialog. 

The viewer uses the search limits you selected until you change them, open 
another document, or click the Clear Limits button on the Document Search 
dialog. If you click the Clear Limits button after limiting the search, the 
viewer redisplays in the Pages Found list those pages that match the 
keyword search only; the search limits that you imposed using the Set 
Document Search Limits dialog no longer apply. 

Viewing a Page After To view one of the pages on the Pages Found list, select the page from the 
Searching list and then click the Go To Page button on the Document Search dialog. 

The viewer closes the Document Search dialog and displays the selected 
page in the viewing window. 

"'" If, after viewing the page, you want to look at one of the other pages on the 
Pages Found list, you can use the Next Page Found and Previous Page 
Found commands on the Search menu. When you choose one of these 
commands, the viewer goes to the next or previous page that appears on 
the Pages Found list. 
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4 Viewing Documents 
When you open a document, the Tandem CD Read viewer displays the first 
page of the document in a viewing window. The window is similar to 
standard document windows in Windows applications: It has a title bar, a 
close box, a zoom box, a size box, and scrolling controls. These features 
operate as described in the Microsoft Windows User's Guide. 

In addition to these standard features that allow you to manipulate the 
viewing window, the viewer allows you to: 

D Control font presentation to provide more readable text on the screen 

D Enlarge the document to view small type and detailed illustrations 

Controlling Fonts The basic Microsoft Windows software is packaged with the Times, 
Helvetica, Symbol, and Courier fonts. Tandem CD Read documents 
typically contain a greater variety of fonts than the Windows software 
package: 

Courier 
Courier-Bold 
Courier-Boldltalic 
Courier Italic 
Palatino-Roman 
Palatino-Bold 
Palatino-Boldltalic 
Palatino-Italic 
Symbol 

Helvetica 
Helvetica-Bold 
Helvetica-Bold Oblique 
Helvetica-Oblique 
Helvetica-Narrow 
Helvetica-Narrow-Bold 
Helvetica-Narrow-Bold Oblique 
Helvetica-Narrow-Oblique 

When a font used in a Tandem CD Read document is unavailable from the 
Microsoft Windows software, the viewer substitutes the unavailable font 
with an installed font that is similar; this substitution sometimes results in 
less than optimal on-screen display. 

Two optional pieces of software can noticeably enhance the screen display 
of fonts used in Tandem documents: Adobe Type Manager and Adobe Plus 
Pack from Adobe Systems. 
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Enlarging Your View 
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4-2 

you might need to enlarge the document to facilitate reading. To do so, 
choose Zoom In from the Page menu. The viewer enlarges the image in the 
viewing window to make it more readable. If the information is still not 
readable, you can repeatedly select Zoom In until the information is the size 
you want. 

.Eile .Edit _eage ~earch 

Ejector 

Thumbscrew 

Nonf unctioni ng 
Indicator Lights ------: 

Thumbscrew ---'---11 .... 1 

Ejector ----....... 1 

.. 
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When you are finished using the enlarged view, choose Zoom Out from the 
Page menu to reduce the image, or choose Normal Size from the Page menu 
to return the image to its normal size. 

As a short cut, if you double-click in the viewing window, the viewer 
enlarges the image to maximum zoom size. If you double-click again, the 
viewer returns the image to normal size. 
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5 Printing Documents 
When you are viewing a document in a library, you can print the entire 
document, a single chapter (also called a section), or selected pages using a 
PostScript printer. If you want to print in landscape orientation rather than 
the default portrait orientation (that is, the printed image is displayed 
across the 11-inch edge of the page rather than across the 8.5-inch edge), 
you must configure the printer accordingly before printing. 

Printing an Entire To print an entire document, do the following: 
Document 

1. Choose Print from the File menu. 

If your printer, for example, is a Hewlett Packard LaserJet printer, the 
viewer displays the following Print dialog: 

HP LaserJet Series II.HPPCLLPT1: I oic I 
Copies: [CJ Pages: OAJI ®from:LJ To: D I Cancel I 

I I Document Information !::!elp ... 

Total pages in document: 307 

Chapter 1 from: 22 to: 48 • 
Chapter 2 from: 49 to: 63 

,-

Chapter 3 from: 64 to: 76 
,-

Chapter 4 from: 77 to: 92 
Chapter 5 from: 93to: 104 
Chaoter 6 from: 105 to: 129 

,-
• 

030 

2. On the Print dialog, click the All button. 

3. Click the OK button to begin printing. 

Printing Chapters To print a single chapter within a document, do the following: 

1. Choose Print from the File menu. 

2. On the Print dialog, click a chapter number from the scrolling list. 

3. Click the OK button to begin printing. 
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Printing Selected Pages 

~' ---------------------------------------
Printing Selected If you want to print less than entire chapters, you can determine which ~ 

5-2 

Pages page or pages you want to print as follows: 

1. Navigate to the first page you want to print as described in Section 3, 
"Accessing Information Within a Document." 

2. Note the absolute page number of the first page, as displayed in the 
page panel on the viewing window. 

3. Navigate to the last page you want to print. 

4. Note the absolute page number of the last page, as displayed in the 
page panel on the viewing window. 

After you have determined which page or pages you want to print, print as 
follows: 

1. Choose Print from the File menu. 

2. On the Print dialog, enter the first page you want to print in the From 
field and the last page you want to print in the To field. You can 
specify page ranges that cross consecutive chapters. 

3. Click the OK button to begin printing. 

Landscape Printing Configure a printer for landscape orientation only if the document you 
want to print is displayed in landscape orientation on the screen. To 
configure the printer, do the following before choosing Print from the File 
menu: 

1. Return to the Microsoft Windows Program Manager. 

2. Select and open the program group that contains the Control Panel 
application (usually the Main program group). 

3. Select and open the Control Panel icon to display the Control Panel 
window. 

4. Select and open the Printers icon to display the Printers dialog. 
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Landscape Printing 

5. Double-dick the printer name, which is listed on the Installed Printers 
list box, to select the default PostScript laser printer. 

6. Click the Setup button to display the PostScript Setup dialog. 

7. Click the Landscape button in the Orientation area of the dialog. 

8. Click the OK button to exit the PostScript Setup dialog. 

9. Click the OK button to exit the Printers dialog. 

10. Close the Control Panel window. 

11. Select Print from the File menu and proceed as described previously in 
this section. 

Refer to the Microsoft Windows User's Guide for more information on how to 
change the printing orientation. 
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6 Marking Information for 
Future Reference 

Bookmark Icon 

Annotation Icon 

New Mark Icon 

Mouse Pointer When 
in the Marks Bar 

After you find the information you want, you can use the viewer to mark it 
so that you can find it quickly in the future. The viewer provides two types 
of marks: bookmarks and annotations. Bookmarks enable you to mark 
information, while annotations enable you to mark information and to add 
your own notes. 

Both bookmarks and annotations appear on the left side of a viewing 
window in a narrow area called the marks margin: 

file fdit fage .§.earch Mark 

? 

Tan em A vance Cornman Language TACL R 

TACL Programmer's Guid'efor moreinforma.tion. 

Using TACL as a TACL is most often used interactively as a comman 

Command Interpreter system startup, your system manager or operator st 

from theTACL program file for ea.ch terminal, inclu 

connected to the system. (The T ACL program file i 

$SYSTEM.SYSn n.TACL, where nn is a two-digit n 

You can then log on to the TACL process at your ter 

system. The TACL LOGON command is d=:ribed I 

you are connected on a network, y0u can also start 

another system; see Section 3 for details.) + 
P- 23 / Cb.apter 1 - P.ago, 2 .. + 

Marks Margin-T 
020 

Marks File All annotations and bookmarks that you create within a library are stored 
in a single file, called a marks file. The viewer places this file in the same 
directory on your hard disk where the viewer application is located. The 
viewer gives the marks file the name of the library followed by a period and 
the extension "ANT" (for example, NT000035.ANT). 

When you alter the marks file by adding, changing, or deleting bookmarks 
or annotations, the viewer creates a backup of the previous marks file 
before it saves the additions, changes, or deletions. This backup has the 
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Creating Bookmarks 

same name as the marks file, except that its extension is "BAK" (for 
example, NT000035.BAK). 

6. Caution If you delete a marks file, you lose all the marks you have created within a library. 

Creating Bookmarks To add a bookmark to a document, use the following procedure: 

6-2 

1. Move the mouse pointer to the left of the information you want to mark 
until the pointer turns into a pointing finger. This change indicates that 
the pointer is in the marks margin. 

2. Click the mouse button to create a new mark. The new mark icon, 
which resembles a question mark, appears in the marks margin. 

3. Choose Add Bookmark from the Mark menu. The viewer displays the 
Save Mark dialog: 

Save Mark 

Bookmark Name: 

I Suspend command 

12;1 Add to Menu 

OK l !..---t-a-nce-1 -. 

021 

4. Enter a name to identify the bookmark if you do not want to use the 
default bookmark name that the viewer provides. 

5. Check the Add to Menu box and click the OK button. 

The viewer closes the Save Mark dialog, changes the new mark icon in 
the marks margin to a bookmark icon, and adds the name of the . .-..., 
bookmark to the Mark menu. ~ 
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Creating Annotations To add an annotation to a document, use the following procedure: 

1. Move the mouse pointer to the left of the information you want to mark 
until the pointer turns into a pointing finger. This change indicates that 
the pointer is in the marks margin. 

2. Click the mouse button to create a new mark. The new mark icon, 
which resembles a question mark, appears in the marks margin. 

3. Choose Annotate from the Mark menu. The viewer displays a blank 
Annotation window, which is illustrated on the following page. 

Enter your margin 
notations here. 

Eile Edit .Search 
+ 

+ 
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You can use a short cut for creating an annotation by double-clicking in 
the marks margin in the same location as you would have clicked to 
create the new mark icon. The viewer automatically displays a new 
Annotation window. 

4. Enter the note you want to make. 

5. After entering your note, choose Close from the File menu. The viewer 
displays the Save Mark dialog illustrated on the following page. 
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Save Mark 

Annotation Name: 

j P8sswords 

1:8:l!Add to Menu! 
QK ! .-I -!;.-an_ce_l---. 

024 

6. Enter a name to identify the annotation if you do not want to use the 
default annotation name that the viewer provides. 

7. Check the Add to Menu box and click the OK button. 

The viewer saves your annotation, closes the dialog, changes the new 
mark icon in the marks margin to an annotation icon, and adds the 
name of the annotation to the Mark menu. 

Instead of choosing Close from the File menu after entering your note, you 
can also choose Save from the File menu. The viewer displays the Save 
Mark dialog previously illustrated in Step 5. Enter a name to identify the 
annotation or use the one provided by the viewer, check the Add to Menu 
box, and click the OK button. The viewer closes the dialog but leaves the 
Annotation window open. To close the Annotation window, choose Close 
from the File menu. 

Locating Marked When you want to refer to information that you have marked, follow these 
Information steps: 

1. Using one of the techniques described in Section 2, "Working With 
Libraries," select and open the document that contains the bookmark or 
annotation you want to locate. 

2. Choose the name of the bookmark or annotation from the Mark menu 
illustrated on the next page. 
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Select the b~okmark-{ 
or annotation you 
want from this list. 

Annotate... Ctrl N 
Add Bookmark... Ctrl B 
Delete Bookmark 
Marks ... 

Suspend command 
Process security 
Job hold status 
Unlabeled tapes 
FUP commands 
Passwords 

F9 

~----------~ 
029 

The viewer goes to the page containing the bookmark or annotation 
and displays the highlighted mark in the viewing window. 

3. If the bookmark or annotation you want does not appear on the Mark 
menu, select Marks from the Mark menu. The viewer displays the 
Marks in Document dialog: 

Marks In Document 

I 

FUP communds *unno pg. 145 ~ 
Job hold stutus *bkmk pg. 221 
Pusswords *unno pg. 35 
Process security *bkmk pg. 259 
Suspend commund *bkmk pg. 35 
Unlubeled tupes *bkmk pg. 167 

* Item is listed on the murk menu 
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.!!_o To Mark 

Delete From Menu 

j!one 

tancel 
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Deleting Bookmarks 

~. 
4. Select from the dialog any marks you may not have added to the Mark 

~ 
menu and click the Go To Mark button. 

The viewer goes to the page containing the bookmark or annotation 
and displays the highlighted mark in the viewing window. 

See the Tandem CD Read Manual for Microsoft Windows Software for more 
information on the Marks command. 

Deleting Bookmarks To delete bookmarks from a document, do the following: 

1. Locate the bookmark within the document using the method described 
in "Locating Marked Information" previously in this section. 

2. Select the bookmark icon on the document page, if it is not already 
highlighted, and choose Delete Bookmark from the Mark menu. The 
viewer displays the following dialog: 

@ Are you sure you want to delete this bookmark? 

~es I I No 

017 

3. Click the Yes button. The viewer deletes the icon and removes the 
name of the mark from the Mark menu. 

Deleting Annotations · To delete annotations from a document, do the following: 

1. Locate the annotation within the document using the method described 
in "Locating Marked Information" previously in this section. 
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Deleting Annotations 

2. Select the annotation icon on the document page, if it is not already 
highlighted, and choose Annotate from the Mark menu. The viewer 
displays the Annotation window containing your notes. 

3. Choose Delete from the File menu. The viewer displays the dialog on 
the following page. 

0 Are you sure you want to delete this annotation? 

~es I I No 

016 

4. Click the Yes button. The viewer doses the Annotation window, 
deletes the annotation icon, and removes the name of the mark from the 
Mark menu. 
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Reader Comment Card 
Tandem welcomes your comments on the quality and usefulness of its 
software documentation. Does this manual serve your needs? If not, how 
could we improve it? Your comments will be forwarded to the writer for 
review and action, as appropriate. 

If your answer to any of the questions below is "no," please supply detailed 
information, including page numbers, under Comments. Use additional 
sheets if necessary. 

Is this manual technically accurate? 

Does it provide the information you need? 

Are the organization and content clear? 

Are the format and packaging convenient? 

COMMENTS 

NAME, COMPANY 

ADDRESS 

CITY, STATE, ZIP 

Tandem CD Read Quick Start for Microsoft 
Windows Software 
Part Number 094578 

...,.1) TANDEM 

Yes No 

D D 
D D 
D D 
D D 

COUNTRY 
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