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sun Draw 

1.1. About the Illustrations 
In This Book 

1.2. Terms and 
Conventions Used In 
This Book 

1 
A Quick Start Guide to SunDraw 

This book is your quick start guide to SunDraw. Use it as a companion to these 
books: 

o The SunDraw Tutorial 

o The SunDraw User's Guide 

If you are not familiar with SunDtaw or have never used a computer-based draw
ing program, read the SunDraw Tutorial. This book gives you an introduction to 
SunDraw. Refer to the SunDraw User's Guide for detailed infonnation about a 
feature or function. 

If you have not yet installed SunDraw, refer to the Installation Guide for 
SunWrite, SunPaint, and SunDraw. 

A combination of SunDraw and SunPaint were used to prepare all of the illustra
tions in this book. 

Tenns that are special to SunDraw and may be new to you, are introduced in 
italic font, for example vector file. These tenns are defined when they are intro
duced. 

The Italic font may also be used to specify variables or parameters that you or the 
system will replace with an appropriate word or string of characters. 

The bo1d typewriter font represents commands you enter at the key
board, exactly as shown. Typewriter font represents what the system 
prints on your workstation screen or printer, or the name of a file. 

The bold roman font is used in the text for the names of SunDraw buttons, set
tings, menus, and menu items. 

+~.!! 3 Revision A of 14 November 1988 



4 SunDraw Quick Start Guide 

1.3. Getting Software Help If you should need help using this product or the accompanying documentation: 

o See the Read This First document for known problems and solutions. A 
Read This First document is supplied with every software product. Your 
system administrator or the person who installed this software should have a 
copy. 

o Look for articles in the Software Technical Bulletin. The technical contact 
person named in your service contract with Sun should have your company's 
master copy. Check the cumulative index for relevant articles. 

o If the Read This First and the Software Technical Bulletin do not help, while 
your software is under warranty or under a software service contract, you 
may get help from Sun by calling the telephone number shown in the Read 
This First. 

o You can order a support contract through your local Sun sales office. 

Revision A of 14 November 1988 
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2.1. How to Start SunDraw 
You use SunPaint in the SunView 
window environment. If you are not 
familiar with Sun View, read the 
"SunView 1 Beginner's Guide" 
before you start SunPaint. 

Starting SunDraw With an 
Open File 

2 
A Guide to Menus and Windows 

This chapter is a quick reference to SunDraw window, menu, and mouse func
tions. 

Type the following command from a Sun View Shell Tool or Command Tool, 
then press the I Return I key. 

To start SunDraw with an open file, type the following command from a Sun
View Shell Tool or Command Tool, then press the ( Return I key. 

l 

4}\sun 
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8 SunDraw Quick Start Guide 

2.2. The SunDraw Window The following illustration shows the SunDraw Window as it appears when you 
start SunDraw. 

Window Mark Window Header Resize Corner 

* SunDraw 1.0 

CEJ!::)~~ (Props )(Arrange) --+--Button Stacks 

Scrollbar 

-----t--t-....-- Page 

~---------====,----------:::!c::J -----------------1rn:JIJ1-----------o 
Window Footer 

• S ll fl RevisionAof14November 1988 
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2.3. Mouse Actions 

c 

Press 

Drag 

Click 

Release 

Chapter 2 - A Guide to Menus and Windows 9 

The following illustration shows all of the mouse actions you use for the LEFf, 
MIDDLE, and RIGHT mouse buttons. 

C11ck LEFT Double Cl1ck LEFT Press LEFT Drag LEFT 

100 

Cl1ck MIDDLE Press MIDDLE Drag MIDDLE Release MIDDLE 

Press RIGHT Drag RIGHT Release RIGlfT 

Press and hold the mouse button without moving the mouse. 

Press and hold the mouse button while you move the mouse. 

Quickly tap and release the mouse button once or twice. 

Release the mouse button you are pressing or dragging. 

Release LEFT 

•\sun ~ microsystems 
Revision A of 14 November 1988 



10 SunDraw Quick Start Guide 

2.4. How to Display and 
Choose From a Menu 

2.5. How to Pin Up a Menu 

1. Point to the Button Stack or Abbreviated Button Stack 

2. Press RIGHT to display the menu 

3. Drag RIGHT to choose a button 

4. Drag RIGHT to choose from the displayed menu 

5. Release RIGHT after you make your choice 

The Props and Mode menus are used in this example. 

~ 
1§1--(;a 

CJ 

0 D 0 0 
~ -z. d ~ 
I-+! 1~1 f-+I i;:i: -) 

1. Choose the menu you want to pin up 

2. Drag RIGHT to choose the Pushpin 

3. Release RIGHT 

Revision A of 14 November 1988 
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2.6. How to Choose From a 
Pop-up Window 

2.7. How to Use a Pop-up 
Window Menu 

[Dismiss )h 

(Back 

(Locate Owner) 

Chapter 2 - A Guide to Menus and Windows 11 

1. Click LEFf on settings 

2. Type new information in text entry fields 

3. Drag RIGHT on Button Stacks to display menus 

4. Drag LEFf on slider bars to change settings 

The Text Properties window is used in this example. 

?J SunDraw: Text Properties 0 -c:::l 

1--_...,._ __ r=-=o=nt::..:....: O Times Roman 

Attribute:~ Bold 1------+---1 I 0 0 
Justify: _L_ef_t-~__,__ _ ____. 

I===== J.~ 

I l=t:===== 0 

Type to change 
these settings 

1. Press RIGHT anywhere on the Window border to display the menu 

2. Drag RIGHT to highlight the button you want to use 

3. Release RIGHT 

The commands on the Pop-up Window menu are: 

o Dismiss: Choose this command to dismiss the window. 

o Back: Choose this command to move the window behind other windows. 

o Locate Owner: Choose this command to move the SunDraw Window to 
the front. 

~~sun ~~ microsystems 
Revision A of 14 November 1988 



12 SunDraw QUick Start Guide 

2.8. How to Use the 
SunDraw Window 
Menu 

((Close 

(Full Size 

)) 

) 

(Back ) 

(~R-ef-r-es-h-------.) 

(Quit ) 

2.9. How to Change a 
Menu Default 

2.10. How to Choose a 
Menu Default 

2.11. How to Move a 
Window 

(Arrange) 

2.12. How to Move a 
Window Back 

1. Press RIGHT anywhere on the SunDraw Window border to display the menu 

2. Drag RIGHT to highlight the button you want to use 

3. Release RIGHT 

The available commands on the SunDraw Window menu are: 

o Close: Use this command to close the SunDraw Window to an Icon 

o Full Size: Use this command to expand the SunDraw Window to the full 
Page size. 

o Back: Use this command to move the SunDraw Window behind other win
dows. 

o Refresh: Use this command to refresh the SunDraw Window ifthe screen 
display develops temporary anomalies. 

o Quit: Use this command to quit SunDraw. 

Note that the Properties command button is grayed. This is because properties 
are not available for the SunDraw window. 

1. Point to the Button Stack 

2. Press the I Control I key and Drag RIGHT simultaneously 

3. Choose the button you want to use for the menu default 

4. Release RIGHT 

1. Click LEFf on the Button Stack or Abbreviated Button Stack 

1. Point to any location on the Window border 

2. Drag LEFf. Move the mouse to drag the window to the new location. 

3. Release LEFf. 

1. Point to any location on the Window border 

2. Drag RIGHT to display the Window menu 

3. Choose Back 

4. Release RIGHT 

Alternatively, you can press the I Front LS I key. 

Revision A of 14 November 1988 
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2.13. How to Move a 
Window Front 

2.14. How to Resize the 
SunDraw Window 

2.15. How to Close 
SunDraw 

2.16. How to Move the 
SunDraw Icon 

sunDr w 

2.17. How to Open 
SunDraw From the 
Icon 

2.18. How to Quit 
SunDraw 

sunDraw 

Chapter 2 - A Guide to Menus and Windows 13 

1. Point to any location on the exposed Window border 

2. Click LEFT 

Alternatively, you can press the I Front L5 I 

1. Point to a Resize comer 

2. Drag LEFT. Move the mouse to increase or decrease the window size 

3. Release LEFT 

1. Point to the Window Mark on the Window header 

2. Click LEFT 

1. Point to the SunDraw icon 

2. Drag LEFT to move the icon to the new location 

3. Release LEFT 

1. Point to the SunDraw icon 

2. Click LEFT 

1. Point to any location on the window border 

2. Drag RIGHT to display the Window menu 

3. Choose Quit 

4. Release RIGHT 

Revision A of 14 November 1988 
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3 
Drawing Objects 

The SunDraw Modes menu provides the following types of modes: 

~ SunDraw: Modes f;) 

/jolol/\ 
.. ------r·····--t·····-·--i-·--··--· 
0 ! Aec ! ..... ,....,.. !.r---.,__+---

1 I I Drawing Modes 
··--·-··-·; ............. t ··--·-······t··-·· 00

--

Anchor Mode 

0101010 
••••••-•••••••-••-•••t•••oo•••oo••• 

~!-zJ 
I ! 

Edit Object Mode 

Point Edit Hodes 

SunDraw starts in Edit mode-labeled ''Edit Object Mode'' in the illustration 
above. To draw an object, you choose a drawing mode. To choose a mode, 
Click LEFf on the mode setting. 

After you draw an object you are automatically in Edit mode. You can then: 

o Edit the object. Refer to Chapter 6 for information about object editing. 

o Choose Again to return to the previous mode. The Again command repeats 
your previous action. For example, you draw a rectangle; you automatically 
go into Edit mode; you choose Again; you are back in Rectangle mode. 
You can choose Again from the Edit menu, or press the I Again L 2 I key. 

o Choose another mode. 

If you want to deliberately choose Edit mode instead of automatically going into 
Edit mode, you can set the Hold Mode Option. When you choose Hold Mode 
you do not automatically go into Edit each time you draw an object. 

•\sun 
• microsystems 
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18 SunDraw Quick Start Guide 

3.1. Drawing Two-Point 
Objects 

3.2. Drawing Three-Point 
Objects 

Two-point objects are: Line, Rectangle, Circle, Ellipse, Freehand, Round 
Rectangle, Polygon. 

1. Choose a drawing mode 

2. Point to a starting position on the Page 

3. Drag LEFf to draw the object 

4. Release LEFf at the ending position. 

000 

Three-point objects are: Arc, Curve, Parallelogram. 

1. Choose a drawing mode 

2. Point to a starting position on the Page 

3. Drag LEFf to draw from point one to point two of the object. 

4. Release LEFf 

5. Move the pointer to define the arc, curve, or parallogram. This is point three 
of the object. 

6. Click LEFf at the ending position. 

•~sun ~ microsystems 
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Drawing Multi-Point Objects 

Chapter 3 - Drawing Objects 19 

...... "' 

Multi-point objects are: Irregular Polygon, Polyline, Bezier Curve, Cyclic 
Bezier Curve. 

1. 

2. 

3. 

4. 

5. 

6. 

7. 

Choose a drawing mode 

Point to a starting position on the Page 

Drag LEFT to draw from point one to point two of the object. 

Release LEFT 

Move the pointer to the next point. 

Click LEFT 

Continue specifying points by moving the pointer and Clicking LEFT until 
you reach the last point. 

8. Double Click LEFT at the end point. 

100 
100 

ODO 

•\sun 
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4.1. Again 

4.2. Undo 

4.3. Redo 

4 

Repeating and Correcting 

You choose repeating and correcting functions from the Edit menu. 

* Edit J9 

(Again ) 
(undo ) 
(copy 

(Paste ) 
(cut ) 

(clear Page 

(select All 

(clone 

(Remove Anchors ) 

Choose Again from the Edit menu to repeat your last action. This can be an 
action such as Clone, a menu choice, or a drawing action. 

The Again command is also available from the keyboard. To use Again from 
the keyboard, press the crn function key. 

Choose Undo from the Edit menu to undo up to five actions. You can use Redo 
to undo an undo command. 

The Undo command is also available from the keyboard. To use Undo from the 
keyboard, press the (Undo L3 I function key. 

Choose Redo from the Edit menu to redo up to the last five Undo commands. 

23 Revision A of 14November1988 



24 SunDraw Quick Start Guide 

4.4. Clear Page 

4.5. Delete 

Choose Clear Page from the Edit menu to remove the entire contents of the 
Page. If you accidentially choose Clear Page, immediately choose Undo to 
restore the Page. 

Choose Delete from the Edit menu to delete all selected objects on the Page. 

You can restore deleted objects if you use Undo immediately after you use 
Delete. 

Alternatively, you can use the I Cut L 10 I key. 

~\sun ~~ microsystems 
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5.1. Copy 

5 
Clipboard Functions 

You choose the Clipboard functions Copy, Paste, and Cut from the Edit menu. 

* Edit J9 

(Again ) 
(undo ) 
(copy ) 
(Paste ) 
(cut ) 

(Clear Page ) 
(select All ) 
(Clone ) 
(Remove Anchors ) 

The Clipboard is a temporary storage location for raster images. SunDraw, Sun
Paint, and Sun Write share the same Clipboard. You can cut or copy a region 

from SunPaint and paste it into SunDraw or Sun Write. Or, you can cut or copy 
an object from SunDraw, then paste it into SunPaint or Sun Write. Of course, you 
can always cut, copy and paste within SunDraw. 

When you choose Copy, select objects are copied from the Page to the Clip

board. The objects are then in two places-the Page and the Clipboard. 

27 Revision A of 14 November 1988 
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5.2. Paste 

5.3. Cut 

When you choose Paste, the last image that was cut or copied to the Clipboard is 
displayed in the center of the Page. You can move the object to a different loca
tion if you wish. If you have the SunDraw Window resized to a small size over a 
large Page you may not see the object when it is pasted. This is because the 
center of the Page may not be visible. You can use Zoom to get an oveiview of 
the Page. When you locate the object, you can scroll or pan the Page to bring the 
object into view. 

When you choose Cut, the selected objects are moved to the Oipboard. 

Revision A of 14 November 1988 
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6.1. Hold Mode 

Options: I Hold Mode 

Hold Mode Off 

Hold Mode On 

'~) 6.2. Selecting Objects 

Selecting a Single Object 

6 
Edit and Perform Actions on Objects 

You can choose to draw with the Hold Mode Option setting turned on or off. 
The Hold Mode setting is on the ToolBox window. To tum Hold Mode on or 
off, Oick LEFf on the setting. 

When the Hold Mode Option is off, you are automatically in Edit mode as soon 
as you have finished drawing an object. 

When the Hold Mode option is on you can continue to draw objects without 
going into in Edit mode. 

You must select an object before you can perform any action with it. 

1. Choose Edit mode 

2. Place the pointer on the object. 

When the object has a transparent fill you place the pointer on the border of 
the object. 

When the interior of the object is filled with a black, white, or gray pattern, 
you can place the pointer anywhere on the object. 

3. Click LEFT 

The object is selected. You can now edit it or perfonn other actions. 

~\sun ~~ microsystems 
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Selecting Multiple Objects 

Extending Selection 

. . 

100 
I 

' 
. . . 

c::J 

You can use any of the following methods to select multiple objects 

o You can extend the selection from one to several objects. 

o You can use marquee selection to select them all at once 

o You can choose Select All from the Edit menu. 

Each method is described in the following sections. 

1. Choose Edit mode 

2. Click MIDDLE on all of the objects you want to select. 

. 

• 

. 

You use the MIDDLE mouse button to extend or reduce selection. Clicking 
MIDDLE on an object acts as a ''toggle'' to select or unselect the object. See 
Unselecting Objects in this section. 

Result 

:o· : 
• • a 0 • • • D 

~---

010 

Revision A of 14 November 1988 

(~ 

C
' 

/ 



Using Marquee Selection 

Chapter 6 - Edit and Perform Actions on Objects 3 3 

When you use the MIDDLE mouse button for marquee selection it acts as a selec
tion toggle. If objects are unselected they are selected. If objects are selected 
they are unselected. When you want to select on1y, use the LEFT mouse button. 

You can use either the LEFf or MIDDLE mouse button to marquee select. 

1. Choose Edit mode 

2. Point to any location on the Page outside the cluster of objects you want to 
select. 

You are going to draw a bounding box that includes all the objects you want 
to select. 

3. Drag LEFf or Drag MIDDLE to draw the bounding box around the objects. 

4. Release LEFf or MIDDLE. All of the objects ate selected and the bounding 
box disappears. 

oo 
u 
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6.3. Unselecting Objects 

6.4. Moving Objects 

You place the pointer on the border 
of transparently-filled objects. You 
can place the pointer on either the 
border or the interior of objects filled 
with a white, black, or gray pattern. 

6.5. Copying Objects 

There are several ways to unselect objects: 

o Choose Edit mode, then Oick MIDDLE on the objects you want to unselect. 

o Choose Edit mode, then use the Marquee selection feature to drag a bound
ing box around the objects you want to unselect. Refer to the Using Mar
quee Selection heading in this section for more infonnation about the Mar
quee feature. 

o Click LEFf anywhere on the Page (except on an object). This action 
unselects all selected objects. 

o Choose Edit mode, then Oick LEFf on an object. Clicking LEFf on an 
object selects that object and unselects all other selected objects. 

You can move an object from one position to another on the Page. When you 
move one object, all other selected objects on the Page also move. So be sure to 
unselect any objects you don't want to move. To move objects: 

1. Choose Edit mode from the Modes menu. 

2. Unselect the objects you do not want to move. 

3. Select the object or objects you want to move 

4. Place the pointer on the border or interior of the object. 

3. Drag LEFf, moving the object to the new position. 

4. Release LEFf 

Sometimes an unusually large or complex object will take a while to move. If 
this is the case, you can use the Drag Frame Only function on the Guides menu 
to speed up the move. The moving process is faster because the object is 
represented by a ''frame'' instead of the actual object. 

You use the Clone function to copy selected objects. To copy an object: 

1. Choose Edit mode from the Modes menu. 

2. Select the object or objects you want to copy. 

3. Choose Clone from the Edit menu. 
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6.6. Rotating Objects 

If the object is large, complex, or 
has an intricate fill pattern the 
Stopwatch symbol may appear. 
When the Stopwatch symbol disap
pears rotation is finished. 

Chapter 6 - Edit and Perform Actions on Objects 35 

You can rotate an object any incremental degree within a full 360 degrees. 

To rotate an object: 

1. Choose Edit mode from the Modes menu 

2. Select the object you want to rotate 

3. Place the pointer on the Rotation Handle. The rotation symbol appears 

The upper right corner handle is the Rotation Handle 

3. Press LEFT. A rotation bounding box appears 

4. Drag LEFT until you have reached the degree of rotation you want 

5. Release LEFT 

• V~ilili:oo 
11111: 

CJ 

• • 

Result 

Revision A of 14 November 1988 



36 SunDraw Quick Start Guide 

6. 7. Stretching and 
Shrinking Objects 

Stretching or Shrinking 
Proportionally 

You use any handle to enlarge or reduce an object by stretching or shrinking it. 
You can stretch or shrink an object proportionally or non-proportionally. 

When you stretch or shrink proportionally the original dimensions of the object 
remain in proportion to one another, even though you enlarge or reduce the 
object. You use any one of the comer handles to stretch or shrink proportionally. 
This illustration shows the object being stretched proportionally. 

0 

To stretch or shrink an object proportionally: 

1. Choose Edit mode from the Modes menu 

2. Select the object you want to stretch or shrink 

3. Place the pointer on top of any corner handle 

4. Press LEFT. A bounding box appears 

4. Drag LEFT to enlarge or reduce the object 

5. Release LEFT 

~~sun ~~ microsystems 
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Stretching or Shrinking Non
Proportionally 
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When you stretch or shrink non-proportionally, you can change the height-to
width or width-to-height ratio of the object. You use the side handles to stretch 
or shrink non-proportionally. This illustration shows the object being stretched 
non-proportionally. 

0 
To stretch or shrink an object non-proportionally: 

1. Choose Edit mode from the Modes menu 

2. Select the object you want to stretch or shrink 

3. Place the pointer on top of any side handle 

4. Press LEFf. A bounding box appears 

4. Drag LEFf to enlarge or reduce the object 

5. Release LEFf 

NOTE The non-proportional handles are affected by the Stretch setting on the Guides 
menu. When Stretch is set to non-proportional, you can use the side handles. 
When Stretch is set to proportional, you can only use the corner handles. 

•\sun ~ microsystems 
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6.8. Nudging and Flipping 
Objects 

Nudge 

You choose the Move/Flip menu from the Arrange menu. You use the menu to: 

o Nudge objects pixel-by-pixel in one of four directions 

o Flip objects horizontally or vertically 

To move selected objects pixel-by-pixel: 

1. Choose Edit mode from the Modes menu 

2. Choose the Up, Down, Left, or Right nudge button 

To move up diagonally, choose Up, then choose Left or Right. To move 
down diagonally, choose Down, then choose Left or Right. 

~~sun ~~ microsystems 
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Flip Horizontally and 
Vertically 

6.9. Changing Appearances 

Change the Fill Pattern 

Chapter 6 - Edit and Perform Actions on Objects 39 

To flip objects horizontally or vertically: 

1. Choose Edit mode from the Modes menu 

2. Choose the Left, Right, Up, or Down flip button 

This illustration shows objects flipped both horizontally and vertically. 

You can easily change the appearance of selected objects. You can change the 

pen pattern, the line width, line style, or fill pattern. This section show you how 

to change the fill pattern, and the line width. 

There are four fill types, they are: white, black, transparent, and a variety of 

''gray'' patterns. 

To change the fill pattern: 

1. Choose Edit mode from the Modes menu. 

This step is not necessary if you have just drawn an object and it is selected. 

2. Select the object you want to change. 

If you have any other selected objects on the Page they will also be changed.· 
Unselect any objects you do not want to change. 

3. Display the Fill menu from the ToolBox window and choose a pattern. 
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Change the Line Width Just as you can change the fill pattern of an object, you can also change the line 
width of the pen border. 

To change the line width of an object: 

1. Select the object you want to change. 

2. Display the Line menu from the ToolBox window. 

3. Choose any line width. 
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7.1. Opening Pictures 

7 .2. Saving Pictures 

7 

Opening and Saving Pictures 

You can open and save SunDraw pictures as Draw, Overlay, Icon, Raster, or 
EPS files. Each file type is described in this chapter. 

To Open a file 

1. Choose Open I Save from the File menu to pop up the Open I Save win
dow. 

* Sun Draw: Open I Save o~ 

Fiie type: I Draw I Overlay I Icon I Raster EPS I 
Directory: /home/server /use rname __ ......... _________ .. ___ ................. ·---··--· .. ·-····· .. --

Fiie: ! I lenam\,_, ___ .. ___ , __ ,,, ___ ,,,_,, __ 

~ (save) 

2. Click LEFf on the File type setting you want to use. You have five choices, 
Draw, Overlay, Icon, Raster, or EPS. 

3. Change the Directory pathname to the directory pathname you want to use 

4. Change the File to the file name you want to use. 

5. qick LEFf on the Open button to display the file on the SunDraw Page 

To Save a picture 

1. Choose Open I Save from the File menu to pop up the Open I Save win
dow. 

2. Click LEFf on the File type setting you want to use. You have five choices, 
Draw, Overlay, Icon, Raster, or EPS. 

I 

When you choose Draw, Icon, Raster, or EPS the entire SunDraw Page is 
saved. When you choose Overlay, only selected objects on the Page are 
saved. 
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Naming SunDraw Files 

7 .3. Description of File 
Types 

Draw Files 
SunDraw is an object-oriented draw
ing program. This means that the 
objects you create are recognized 
by Sun Draw as a specific forms 
with specific properties. This is 
quite different than a pixel-oriented 
(sometimes called raster-oriented) 
program like SunPaint which recog
nizes only masses of pixels, not 
individual objects. 

Overlay 

Icon Files 

3. Change the Directory pathname to the directory pathname you want to use 

4. Change the File to the file name you want to use. 

5. Click LEFf on the Save button to save the current picture on the SunDraw 
Page. 

To help you or someone else identify the files you create with SunDraw, you 
should consider adopting the following file naming conventions: 

o Name Draw files: filename. draw or filename. dr 

o Name Overlay files: filename. overlay or filename. ov 

o Name Icon files: filename. icon or filename. ic 

o Name Raster files: filename. raster or filename. rs 

o Name EPS files: filename. eps 

You can use the following characters as part of a SunDraw file name: 

a-z, A-Z 0-9, I 

If you try to save file with a name that includes any characters other than the ones 
listed above, the error message "Unallowable file name" appears. If this occurs, 
enter a new file that is composed of ''allowable'' characters. 

Draw files are in vector format. The vector format preseives the object
orientation of SunDraw pictures. When you save a picture to a Draw file, you 
can open it again, then select objects and perform any actions you like. You can 
add new objects or delete existing ones. When you save to a Draw file, all of the 
objects on the SunDraw Page are saved, regardless of the selection status of the 
objects. 

You can open a Draw file as an Overlay because these file types share the vector 
format. However, you cannot open a Draw file as any other file type. You can
not open a Draw file in SunPaint or Sun Write. 

You use Overlay files to open and save selected objects. You can save one or 
several selected objects to an Overlay file. Overlay files, like Draw files, are in 
vector format. You can open an Overlay file as a Draw file. However, you can
not open an Overlay file as any other file type. You cannot open an Overlay file 
in SunPaint or Sun Write. 

Icon files are in Sun View icon format. The Icon format is used to create icons, 
pointer symbols, and panel features for Sun View programs. The SunView 1 
Beginner's Guide describes the Sun View Icon Editor. The Sun View 1 
Programmer's Guide describes the icon format and the ways that you can use 
icons. You can interchange SunDraw and SunPaint Icon files. 
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Raster Files Raster files can be used by Sun Write, SunPaint, raster-oriented programs, or 
applications that accept raster files. SunDraw raster files contain the mapping of 
all white pixels and all black pixels as they appear on the screen. 

EPS Files BPS stands for Encapsulated Postscript. This file format type is specifically for 
saving pictures that you are going to include in Sun Write documents. The 
printed results of an EPS picture are superior to the printed results of a SunDraw 
raster file. 

CAUTION Once you save a SunDraw picture to EPS format you cannot reload it into 
SunDraw. This is not a problem unless you want to modify the file at some 
future time. To provide a safeguard, you might want to save any pictures 
you intend to use with Sun Write to two file types-EPS and Draw. 
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Printing Pictures 

There are three ways you can print your current picture: 

o Choose Print Picture from the Print menu. You display the Print menu 
from the File menu. 

o Choose Printer Settings from the Print menu to pop up the Printer Set
tings window. Make any necessary changes to the settings. Click LEFf on 
the Print command button at the bottom of the window. 

o If you have set Print Picture as the Print menu default, and have also set 
Print as the File menu default, you can Click LEFT on the File Button Stack 
to print your picture. 

)) 

(Printer Settings *) 

* SunDraw: Printer Settings 

Print as: I Postscript I Raster Image 

Destination: I Printer I File I 
Printer Name: lw . 

....• "!I ........................................................ ·--·······-·-·········--····· .. ··········--·---····-· 

The SunDraw User's Guide provides detailed information about the Printer Set
tings window. 

•\sun ~~ microsystems 
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